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Introducing LogoSpruce

Thank you for purchasing LogoSpruce, the premier collection of manual tracing tools for Adobe® Illustra-
tor®.  

Perhaps the fi rst question you may ask is “Why should I manually trace anything?  With so many auto-
tracing tools available, why not use them?”  When a sign-maker fi rst suggested this software to us, we 
thought the same thing, and pestered him with questions.  Auto-trace works wonders, he clarifi ed, if you’re 
starting with a nice, clean image.  But, if you’re trying to trace a smudged, faxed, and/or scanned logo, 
auto-tracing produces an image too rough to immediately use.  So, he said, he spends hours editing many 
of his customers’ logos by hand.  In the end, he wondered, wouldn’t it be faster to just do the job manually 
from the beginning?  

Well, we decided to accept his challenge and create a set of manual tracing tools. (Besides, he said he would 
buy a copy, if it were any good.) After a few months (and more than a small dose of his practical wisdom), 
we showed him our fi nished tools.  

And he liked them.  We hope you do too.
—The LogoSpruce team

Please make sure you have the following:

• Quick Start Guide

• Installation CD  

• End User License Agreement 

The LogoSpruce User Manual is included on the installation CD-ROM in PDF format. In order to read it, 
you will need Adobe’s free Acrobat Reader. (If you do not already have a copy, it is available in the Acrobat 
folder on the CD or from Adobe’s web site: http://www.adobe.com)

Registering your copy of LogoSpruce

Please fi ll out the user registration card on page and send it to our technical support staff by fax or email. 
Alternately, visit our web site at http://www.comnet-network.co.jp/eng/register/ and register on-line.  By 
registering your copy of LogoSpruce, you are entitled to free technical support.  We will also notify you 
of upgrades as they are released.  If you do not register your software, we cannot guarantee a prompt 
response to your questions.

http://www.adobe.com
http://www.comnet-network.co.jp/eng/register/
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System Requirements

Installing LogoSpruce is like installing any other software, with one exception.  Since LogoSpruce works in 
conjunction with Illustrator, it must be installed in Illustrator’s plug-ins folder.  For more information about 
Illustrator plug-ins and how to change the plug-ins folders, please see the Illustrator User Guide.

Most of the time, however, the plug-ins folder is in the default location.  If you do not think you have 
changed its location, please follow the instructions below to install LogoSpruce. 

Installing LogoSpruce

On the Macintosh     (Windows users:  see page 3)

1. Insert the installation CD into your CD ROM drive.
2. Double click on the CD labeled LogoSpruce.  It should appear on your desktop automatically.
3. By double clicking on the LogoSpruce Installer icon, launch the LogoSpruce installation program.

Macintosh 
• Adobe Illustrator 7.0 - 9.0
• Mac Classic OS 8.0 or later
• Power Macintosh or compatible
• RAM suffi cient to run Illustrator
• CD-ROM drive

Windows
• Adobe Illustrator 7.0 or later
• Microsoft Windows 95/98, ME,
  Windows NT, 2000 or XP
• Intel Pentium or faster processor
• RAM suffi cient to run Illustrator
• CD-ROM drive

4. Please follow the installation instructions
            as they appear on your screen.  When you
            are asked to assign an installation
            directory, please choose the Illustrator’s
            plug-ins directory.

5. For example, please see the fi gure on the 
 right.

6. After fi nishing the installation, the next
            time you start Illustrator, you will be 
            asked to unlock your copy of LogoSpruce.  
            Instructions are on page 4. 
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On Windows

1. Insert the installation CD into your CD ROM drive.
2. Double click on the My Computer icon.
3. In the next window, you should see a CD ROM icon labeled LogoSpruce.  By double clicking on it,
            you will fi nd a “Setup.exe” program.  Double click that program to start the installation. 
4. Please follow the installation instructions as they appear on your screen. When you are asked to
            assign an installation directory, please click “Browse” to choose Illustrator’s plug-ins directory.

5. For an example Installation directory, please see the fi gure below. 

6. After fi nishing the installation, 
            you will be asked to restart 
            your computer.  The next
            time Illustrator is started, you 
            will be prompted to unlock 
            your copy of  LogoSpruce.  
            For help, please see the 
            instructions on the next page.
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Unlocking your copy of LogoSpruce

The fi rst time you launch Illustrator after installing LogoSpruce, you will be prompted for your registration 
code.  This code can be found on the Quick Start Guide included in your LogoSpruce package.  Please be 
sure to enter your user name and password exactly as it appears on the paper.  

If you purchased your copy of LogoSpruce on-line, your key will be mailed to you by your software 
vendor.  If you do not receive a key, or have any questions they cannot answer, please contact us at 
register@comnet-network.co.jp.

After you have entered your user name and password, click register. Once you have successfully entered 
your registration code, LogoSpruce’s tools and menus will appear in Illustrator.  

Happy tracing!

Questions? Ask here.

If you have any technical questions about this product after purchase (could not be installed, the installation 
CD is defective, or you’d like help using LogoSpruce), please let our technical support staff know by sending 
us an email at support@comnet-network.co.jp.   We promise to respond to registered users questions by 
the next business day.

If you have any questions about your registration code, please contact us at register@comnet-network.co.jp.  
In your email, please let us know where you purchased LogoSpruce.  

Information about software upgrades, user tips, and other information can be found on the Comnet web site: 
http://www.comnet-network.co.jp

http://www.comnet-network.co.jp/
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Overview of LogoSpruce’s Tools and Menus

After installing LogoSpruce, you will discover new tools and menu options in Illustrator.  This next section 
provides a brief description of LogoSpruce’s menus and tools.

New Menu Items

In the View Menu

Three functions -- “Auto Guide (Display)”, “Auto Guide (Object)” and “Erase One-Touch Guide” -- are added to 
the View menu.

Auto Guides

Each of the trace tools in LogoSpruce has optional Auto Guides.  
Auto Guides identify useful points (like end points, midpoints or 
intersections), and useful directions (like the tangent, 90 degree, 
or 45 degree).  There are also Auto Guides for the artboard.  
They identify the horizontal, vertical and 45 degree directions with 
respect to the artboard.  Each trace tool can use one or both of the 
Auto Guides.  For more details, please see page 9.

One-Touch Guides

Guides in half the time: Use the One-Touch Guide tools to quickly 
and accurately place guide objects.  The “Erase One-Touch Guide” 
command deletes all guides created with the One-Touch Guide 
tools.

In the Window Menu

“Set Fillet Radius” is added to the Window menu.   By selecting Window > Set Fillet Radius, you can enter a 
numerical value for the Fillet radius.
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New Tools

LogoSpruce also adds various tools such as tracing tools, drawing tools, and guide tools to Illustrator’s Toolbox

Tracing tools

Line Trace Tool
Use this tool to create straight lines.

For more information about LogoSpruce’s trace tools, see page 10.

Tangent Arc Trace Tool
Use this tool to create an arc tangent to the previously drawn path.  By 
clicking and dragging, you can adjust the radius and length of the arc.

3-Point Arc Trace Tool (S, E, M)
Use this tool to create an arc by specifying a starting point, ending point, 
and midpoint, in that order.

3-Point Arc Trace Tool (S, M, E)
Use this tool to create an arc by specifying a starting point, midpoint, and 
ending point, in that order.

Bezier Trace Tool
Use this tool to create a Bezier curve by specifying a starting point, 
ending point, and an apex connecting these two points.

Tangent Bezier Trace Tool
Use this tool to create a Bezier curve tangent to the previously drawn 
path by specifying a starting point, ending point, and a connecting apex. 

Drawing Tools
Boxed Ellipse
Draw an ellipse with a guide illustrating the ellipse’s bounds.  
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Inclined Ellipse Tool
Use this tool to create an inclined ellipse.

2-Point Circle Tool
Use this tool to create a circle between 2 user-defi ned points.

Inclined Rectangle Tool
Use this tool to create an inclined rectangle.

For descriptions and examples of how to use LogoSpruce’s Drawing 
tools, please see page 12.

Trimming Tools

2-Point Cut Tool
Use this tool to cut (delete) the area between 2 user-defi ned paths.

X Trimming Tool
Use this tool to shorten the path segments of a user-specifi ed corner. 

T Trimming Tool
Use this tool to shorten a line segment intersecting a user-specifi ed line 
segment.

One-Touch Guide Tools

With a click of the mouse, use these tools to easily create ruler-style guides.

Cross One-Touch Guide Tool
Use this tool to create a cross-shaped guide with one touch of the mouse.

Horizontal One-Touch Guide Tool
Use this tool to create a horizontal guide with one touch.

For descriptions and examples of how to use LogoSpruce’s Trimming 
tools, please see page 13.
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Vertical One-Touch Guide Tool
Use this tool to create a vertical guide with one touch.

Tangent Line One-Touch Guide Tool
Using this tool,  create guides tangent to the path of your choice.

One-Touch Guide Copy Tool
Use this tool to easily copy guides created with any of the One-Touch 
Guide tools.

For suggestions how to use the one touch guides, please see page 14.

Other Tools

LogoSpruce also has other tools useful for tracing.

Fillet Tool
Wtih this tool, round corners of rectangles or other polygons.

Raster Image Rotation Tool
Use this tool to align a raster image for tracing.

For descriptions and examples of how to use these tools, please see page 
15.
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Using Auto Guides

LogoSpruce’s tracing tools have “snap-to” Auto Guides, 
to assist you in tracing images.  The Auto Guides identify 
various directions, such as perpendicular or 45 degree 
directions, and useful points on an object, such as mid-
points, tangent points and endpoints.  

When the Auto Guides are activated, the cursor changes 
to show when your mouse is in the corresponding posi-
tion.  In Figure 1 you can see all of the possible direc-
tional Auto Guides for an object.  

Activate the Auto Guides by selecting View > Auto 
Guides (Object).  Alternately, select View > Auto Guides 
(Artboard) to activate Auto Guides with respect to the 
artboard.  It is possible to use both types of Auto Guides 
at the same time.

Figure 1: Auto Guides (Object)

The Auto Guide cursors

Auto Guides for Objects and Paths

End Point
Indicates the end point of a line segment.

Midpoint 
Displayed when the cursor is over the 
midpoint of a straight path segment.

Tangent Line
Indicates that the cursor path position is 
in the tangent line direction with respect 
to the immediately preceding path seg-
ment.

45° Direction 
Indicates that the cursor path position 
is in the direction 45° from the immedi-
ately preceding path segment.

90° Direction 
Indicates that the cursor path position 
is in the direction 90° from the immedi-
ately preceding path segment.

Intersection with Path 
Indicates that the cursor position is over 
a path segment.

Auto Guides for the Artboard

45° Direction 
Indicates the cursor path is at a 45 
degree angle with respect to the art-
board.

Horizontal
Indicates that the cursor path is parallel 
to the base line of the artboard.

Vertical
Indicates that the cursor path is perpen-
dicular to the base line of the artboard.

Guides 
Indicates that the cursor is over a guide.

Guide Intersection 
Indicates that the cursor is at the inter-
section point of two guides.
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Using the Tracing Tools

LogoSpruce’s tracing tools are the basic tools used for 
tracing a logo or design.   A key difference between 
Illustrator’s pen tool and LogoSpruce’s tracing tools, is 
you can preview the line before you draw it. 
  
In the trace tool pallet, there are three main types of 
tools:  a straight line, an arc, and a bezier curve.  With 
two related tools, the Tangent Arc tool and the Tangent 
Bezier tool, you can quickly draw arcs that intersect with 
previously drawn lines seamlessly.  

Since most logos are not just a set of straight lines, 
there are shortcut keys to allow you to switch between 
tracing tools quickly.  Any time you are using one of 
LogoSpruce’s tracing tools, by pressing the Option key 
(Macintosh) or the Alt key (Windows), you can rotate 
between the Line Trace tool, the 3 Point Arc Trace tool 
(S, M, E), and the Bezier Trace tool.  

Also, to speed up your tracing, if the Auto-guides are on 
and you start a traced line by clicking either end-point 
of a previously drawn path, you can add additional seg-
ments to that path quickly and easily.

Line Tracing Tool
Use the Line Trace tool, instead of the Pen or Pencil tool, 
when you need to trace straight lines. Begin drawing by 
clicking to defi ne a start point, then click and drag the 
cursor to draw a straight line.  You will see the line as 
you drag the cursor.  When you release the mouse button, 
you have “drawn” the line.  If you don’t de-select the 
object you are currently drawing, you can continue to 
trace by clicking additional points.

Pressing the Option key (Macintosh) or the Alt key (Win-
dows), changes the Line Trace tool to the 3 Point Arc (S, 
M, E) Trace tool.

By pressing the Shift key, the possible directions of 
the path will be fi xed to either the same direction as 
the path drawn immediately before, or to a direction 
perpendicular to that path.

Tangent Arc Trace Tool
Use the Tangent Arc tool to draw an arc in the tangent 
line direction of the immediately preceding path seg-
ment.  This is particularly useful when trying to draw 
arcs that intersect smoothly with a straight segment. 

Pressing the Option key (Macintosh) or the Alt key (Win-
dows), changes Tangent Arc tool to the Bezier Trace tool.

3 Point Arc Trace Tool (S, M, E)
Use this tool to create an arc by specifying 3 points: the 
starting point, a middle point, and ending point, in that 
order.

3 Point Arc Trace Tool (S, E, M)
Use this tool to drawn an arc by specifying 3 points:  the 
starting point, ending point and a point in the middle, 
in that order.  Just so there is no confusion — middle 
is defi ned loosely, because it’s easier to remember; the 
middle point may not actually bisect the arc.
 
Pressing the Option key (Macintosh) or the Alt key (Win-
dows), changes the 3 Point Arc Trace tool (S, E, M) to 
the Bezier Trace tool.

Pressing and holding the Shift key allows you to draw a 
Tangent Arc without changing tools.

Tangent Arc Tool
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Tangent Bezier Tool
Use this tool to create a Bezier curve by specifying a 
starting point, ending point, and an apex point connecting 
the starting and ending points.  This tool works in the 
same way as the Bezier Trace tool, but a Bezier curve 
can only be created with respect to the tangent direction 
of a straight line path. Using this tool to draw a curve 
makes it possible to easily create a path that smoothly 
connects to a curve.

Pressing the Option key (Macintosh) or the Alt key (Win-
dows) changes the Tangent Bezier Trace tool to the Line 
Trace tool.

Pressing the Option key (Macintosh) or the Alt key (Win-
dows), changes the 3 Point Arc Trace tool to the Bezier 
Trace tool.

As with the other 3 Point Arc Tool, pressing and holding 
the Shift key allows you to draw a Tangent Arc without 
changing tools.

Bezier Trace Tool 
Use this tool to create a Bezier curve by specifying a 
starting point, ending point, and an apex point connecting 
the starting and ending points.  If you click and drag 
when defi ning the apex point, you can modify the curve’s 
position. 

Pressing the Option key (Macintosh) or the Alt key (Win-
dows) changes the Bezier Trace tool to the Line Trace 
tool.

Pressing and holding the Shift key will draw a Tangent 
bezier instead.

In the example on 
the right, P1 and 
P2 are the fi rst two 
points created.  Then, 
by clicking at P3 
(the apex point), the 
Bezier line appears. 
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Using the Drawing Tools

When tracing an object, certain shapes are used more 
often than others.  To help you draw those shapes more 
easily, LogoSpruce has a few new drawing tools.

Boxed Ellipse Tool
Use this tool to create an ellipse by specifying opposing 
angles of a rectangle that defi nes the ellipse size. This 
tool is often used to trace a distorted ellipse in a raster 
drawing. When used in conjunction with the One-Touch 
Guides (described later), this tool can be used to easily 
trace circular shapes. 

To specify the rectangle, click P1 and P2, in that order, 
as shown in the example on the left.  The ellipse appears 
within the rectangle; note that the rectangle disappears 
when you have fi nished drawing the ellipse.

Press and hold the Shift key to create a circle inside 
the bordering rectangle.  The diameter of the circle will 
always equal the shorter of the rectangle’s two sides.

Inclined Ellipse Tool
This tool is used in much the same way as the ellipse tool 
in Illustrator.  However, ellipses drawn with this tool are 
oriented along an angle of your choosing. 
 
First, using the Inclined Ellipse tool, draw the baseline.  
This line determines the orientation of the ellipse.  Then, 
by clicking and dragging, draw the inclined ellipse.  It 
might help to think of this as “pulling” the ellipse from 
baseline.   

If you press and hold the Shift key, the ellipse will be 
centered on the baseline. 

2-Point Circle Tool
With the 2-Point Circle tool, quickly draw circles by 
clicking and dragging.  The distance between the point 
where you fi rst click and the point where you release the 
mouse becomes the diameter of the circle.

Inclined Rectangle Tool
Similar to the Inclined Ellipse tool, the inclined rectangle 
tool is used to create a rectangle oriented to an angle of 
your choice.  To easily draw an inclined rectangle:

1,  Click and drag the cursor to draw the baseline.
2.  Click a point away from the baseline to draw the
     rectangle. 

As shown in the fi gure to 
the left, click P1 then drag 
the mouse to  P2, to create 
a straight line that corre-
sponds to the angle of the 
inclined rectangle.

Next, drag the cursor path to P3 to create an inclined 
rectangle with the lines defi ned by P1 and P2 as its base. 

Press and hold the Shift key 
to create an inclined rectan-
gle centered along the base-
line.
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Using the Trimming Tools

Middle Trim Tool
Use this tool to delete a portion of a path located between 
2 path segments.   This is helpful when manually tracing   
images -- instead of wasting time aligning end points, 
draw a rough sketch and trim the excess afterwards.
  
Using Illustrator’s knife and direct selection tool, you 
can do some of the work the trim tools do, but the trim 
tools allow you to do it faster!

First, identify the paths that bound the segment you 
would like to delete, by clicking a point on each path.  
(P1 and P2 in examples 1 and 2.)

The third path segment (P3) you click will be deleted.  

However, when trying to trim a path segment that inter-
sects more than two paths, it’s important to select the 
closest intersecting paths. In example 1, you see that 
P1 is on the path that is closest to P3.  Similarly, by 
changing the position of P1 in example 2, a different 
segment is trimmed.

X Trimming Tool
Use this tool to trim the 2 selected path segments (P1 and 
P2) to the point at which they intersect.

T Trimming Tool
With this tool, by clicking on the fi rst path at P1 and then 
the second path at P2,  the second path is trimmed to the 
point at which it intersects the fi rst.

 If the fi rst point selected isn’t on the closest intersecting 
path, you may delete segments other than the ones 
intended, as in Example 3.  

Example: X Trim

Example: T trim

Example 1

Example 2

Example 3
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Using the One-Touch Guides

The one touch guide tools allow you to place guides 
quickly and easily, in a variety of positions:  angled, 
horizontal, or vertical.  With each of the One-Touch 
Guide tools, you can preview the guide location before 
placing it, by clicking and dragging.  When the mouse 
button is released, the One-Touch Guide is placed.  

To quickly erase all One Touch Guides, choose View 
> Erase One Touch Guides.  Note:  This will only 
erase guides created with the One Touch Guide tools.  
However, the View > Clear Guides command will clear 
both regular guides and One Touch Guides.

When using the Horizontal, Vertical, or + One Touch 
Guide tools, their orientation can be changed by pressing 
the Option key (Macintosh) or the Alt key (Windows) 
and dragging the mouse in the direction you would like 
to rotate the guide.

Create guides with the same orientation as the last guide 
placed by pressing the Shift key when placing the new 
guide.  This works for any of the above guides.

To use the Tangent One Touch Guides most effectively, 
you must also activate the Auto-Guides (Object) found in 
the View menu.. When the Auto-Guides identify a path 
the One-Touch Guide will snap to align itself with that 
path.  

The Tangent One 
Touch guides also 
snap to endpoints or 
midpoints of a path.

When placing a Tan-
gent One touch guide 
at the intersection 
point of two paths, by pressing the Option key (Macin-
tosh) or the Alt key (Windows), select which path the 
guide should follow.

Tangent One-Touch Guides

One-Touch Guide Copying Tools
The One-Touch Guide Copy tool allows you to create a 
series of guides in a few short steps.
  
Using the One-Touch Guide Copy tool, select the One-
Touch guide you would like to copy.  You will be 
prompted to enter the guide spacing distance and the 
number of copies you would like to make. 
 

When a positive 
number is entered for 
the distance, the guide 
copies appear to the 
right (or above) of the 
original guide.  When 
a negative number is 
entered, the guide 
copies appear to the 
left (or below).

Note:  the number of copies does not include the guide 
being copied. 
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Using the Other Tools

Last, but certainly not least in LogoSpruce’s box of tricks 
are the Raster Image Rotation tool and the Fillet tool..

Raster Image Rotation Tool
When a raster image to be traced needs to be squared 
with the artboard before tracing, use the Raster Image 
Rotation tool.  Drag the Raster Image Rotation Tool 
along the edge to be squared.  Upon releasing the mouse 
button, the image is rotated so that the dragged line aligns 
squarely in the horizontal or vertical direction.

Fillet Tool
Use the Fillet tool to fi llet corners of squares, rectangles, 
or other polygons.

By choosing the View > Fillet Settings… menu item, you 
can display the Fillet Settings dialog box.  The Fillet tool 
dialog box has an input area for entering the fi llet radius 
and a check box for selecting whether or not the specifi ed 
radius is to be applied to the fi llet.  How you draw a fi llet 
differs depending on whether or not the “Use Radius” 
box is checked.

Creating a Fillet by Specifying the Arc Radius

If the “Use Radius” box is checked, you can create a 
fi llet with the specifi ed value as its radius by clicking 2 
straight lines.

If the specifi ed radius value is negative, the corner point 
becomes the center of the fi llet diameter, with the fi llet 
rounding inward.

Freehand fi lleting
If “Use Radius” is not checked, the radius of the fi llet 
is by dragging the mouse.  Select the fi rst and second 
straight lines in the same way as when applying the 
specifi ed radius. You must also select a third point that 
indicates the center of the 
arc that will create the fi llet. 
By dragging the cursor, pre-
view the fi llet.

When drawing a fi llet 
radius freehand, you can 
still use the radius set in the fi llet settings by pressing 
shift.  The previewed fi llet will automatically snap to the 
set radius.
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Registering LogoSpruce — Please register!

Title:     Mr.     Ms.     Dr.     Other:                           

Name:

email:

Company:

Address 1:

Address 2:

City:      State:

Country:     ZIP/Postal Code:

Phone:     Fax:

Operating System:    Mac 8    Mac OS 9    Mac OS X  
             
              Windows 95/98/ME   Windows NT/2000  Windows XP

Illustrator version:    7       8        9      10      

Date of purchase:                   

  
Would you like to be contacted about upgrades or updates?  

How did you fi rst hear about LogoSpruce?

Our privacy policy:

Your personal data is yours.  We won’t share it, nor contact you without your permission.  For more details, please see:  http://www.comnet-network.co.jp/eng/privacy/

1.  Friend
2.  Print Advertisement
3.  On-line advertisement
4.  Trade show

Please complete and fax this card to:  +81-6-6305-2191        (outside of Japan)   
                                     06-6305-2191             (within Japan)
  
Alternately, register on-line at http://www.comnet-network.co.jp/eng/register/

5.  Review
6.  Direct mail
7.  Email

Purchase place:

Yes  No

http://www.comnet-network.co.jp/eng/register/
http://www.comnet-network.co.jp/eng/privacy/
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